Coolant temperature sensor

Have a problem with your A45? Or just want to get some technical advice? Here's the place!
Post Reply
P30egy
New User
New User
Posts: 37
Joined: Thu Mar 22, 2018 5:18 am

Coolant temperature sensor

Post by P30egy » Sat Jan 12, 2019 2:50 pm

Anyone know the location of this I’ve recenty had my thermostat replaced but the gauge is still dropping while driving. So I’m hoping it’s a sensor.
0 x

User avatar
MAFFA
Moderator
Moderator
Posts: 4373
Joined: Wed Dec 21, 2016 10:03 pm
Location: Bognor Regis
x 485
Contact:

Re: Coolant temperature sensor

Post by MAFFA » Sun Jan 13, 2019 12:02 am

Image
0 x
2014 A45 AMG ¦ Jupiter Red ¦ AMG Aero Pack ¦ AMG De-Resonated Sports Exhaust ¦ 19" AMG Alloys ¦ AMG Exclusive Pack ¦ Full Leather incl. Heated Seats & Leather Dashboard ¦ Panoramic Sunroof ¦ AMG Night Pack ¦ Privacy Glass

User avatar
MAFFA
Moderator
Moderator
Posts: 4373
Joined: Wed Dec 21, 2016 10:03 pm
Location: Bognor Regis
x 485
Contact:

Re: Coolant temperature sensor

Post by MAFFA » Sun Jan 13, 2019 12:04 am

Thermostat is a pig of a job as it’s right at the back of the engine & if the sensor is knackered it’d be just as hard to replace.

I had issues with my temps & replacing the thermostat sorted it
0 x
2014 A45 AMG ¦ Jupiter Red ¦ AMG Aero Pack ¦ AMG De-Resonated Sports Exhaust ¦ 19" AMG Alloys ¦ AMG Exclusive Pack ¦ Full Leather incl. Heated Seats & Leather Dashboard ¦ Panoramic Sunroof ¦ AMG Night Pack ¦ Privacy Glass

P30egy
New User
New User
Posts: 37
Joined: Thu Mar 22, 2018 5:18 am

Re: Coolant temperature sensor

Post by P30egy » Sun Jan 13, 2019 2:05 am

I was hoping that replacing the thermostat would have sorted the problem. Thing is had the temp drop but no eml light like before. I’ll get it back in the garage but I can’t think of anything else other than air in the system.
0 x

User avatar
MAFFA
Moderator
Moderator
Posts: 4373
Joined: Wed Dec 21, 2016 10:03 pm
Location: Bognor Regis
x 485
Contact:

Re: Coolant temperature sensor

Post by MAFFA » Mon Jan 14, 2019 8:28 pm

P30egy wrote:I was hoping that replacing the thermostat would have sorted the problem. Thing is had the temp drop but no eml light like before. I’ll get it back in the garage but I can’t think of anything else other than air in the system.
Yeah I got an EML & replacing it fixed that. Maybe the system has an air lock but in my experience on other cars when the WTS goes the water temps get really high as the fans don’t know when to kick in. Either that or the exact opposite & the fans are going constantly.
0 x
2014 A45 AMG ¦ Jupiter Red ¦ AMG Aero Pack ¦ AMG De-Resonated Sports Exhaust ¦ 19" AMG Alloys ¦ AMG Exclusive Pack ¦ Full Leather incl. Heated Seats & Leather Dashboard ¦ Panoramic Sunroof ¦ AMG Night Pack ¦ Privacy Glass

Post Reply